about summary refs log tree commit diff
path: root/nix/users/fcuny/1password.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /nix/users/fcuny/1password.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/1password.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/nix/users/fcuny/1password.nix b/nix/users/fcuny/1password.nix
index fd1dfbe..bf8133f 100644
--- a/nix/users/fcuny/1password.nix
+++ b/nix/users/fcuny/1password.nix
@@ -1,11 +1,13 @@
 { config, ... }:
 let
   home = config.home.homeDirectory;
-  darwinSockPath =
-    "${home}/Library/Group Containers/2BUA8C4S2C.com.1password/t/agent.sock";
+  darwinSockPath = "${home}/Library/Group Containers/2BUA8C4S2C.com.1password/t/agent.sock";
   sockPath = ".1password/agent.sock";
-in {
-  home.sessionVariables = { SSH_AUTH_SOCK = "${home}/${sockPath}"; };
+in
+{
+  home.sessionVariables = {
+    SSH_AUTH_SOCK = "${home}/${sockPath}";
+  };
 
   home.file.sock = {
     source = config.lib.file.mkOutOfStoreSymlink darwinSockPath;
@@ -18,7 +20,9 @@ in {
     '';
   };
 
-  programs.ssh = { extraConfig = "IdentityAgent ~/${sockPath}"; };
+  programs.ssh = {
+    extraConfig = "IdentityAgent ~/${sockPath}";
+  };
 
   # Generate ssh agent config for 1Password
   # I want both my personal and work keys