about summary refs log tree commit diff
path: root/nix/profiles/home-manager/zsh.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-05-23 09:20:17 -0700
committerFranck Cuny <franck@fcuny.net>2024-05-23 09:20:17 -0700
commit49588c5716557635f945752436afb8f16b2230d8 (patch)
tree4a86b1e40d7c72c58095d2a184739a320505fa6d /nix/profiles/home-manager/zsh.nix
parentchore: update flake (diff)
downloadworld-49588c5716557635f945752436afb8f16b2230d8.tar.gz
clean up a bunch of home-manager stuff
No need for alacritty, tmux, firefox, and zsh.
Diffstat (limited to '')
-rw-r--r--nix/profiles/home-manager/zsh.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/nix/profiles/home-manager/zsh.nix b/nix/profiles/home-manager/zsh.nix
deleted file mode 100644
index e704870..0000000
--- a/nix/profiles/home-manager/zsh.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{ config, pkgs, ... }:
-{
-  home.packages = with pkgs; [ zsh-completions ];
-
-  programs.zsh = {
-    enable = true;
-    dotDir = ".config/zsh";
-
-    defaultKeymap = "emacs";
-    enableCompletion = true;
-    enableAutosuggestions = true;
-
-    history = {
-      size = 500000;
-      save = 500000;
-      extended = true;
-      ignoreSpace = true;
-      ignoreDups = true;
-      share = true;
-      # see
-      # https://github.com/nix-community/home-manager/blob/32a7da69dc53c9eb5ad0675eb7fdc58f7fe35272/modules/programs/zsh.nix#L537
-      path = "${config.xdg.dataHome}/zsh/zsh_history";
-    };
-
-    localVariables = {
-      # Print timing statistics for everything which takes longer than
-      # 5 seconds of user + system time.
-      REPORTTIME = 5;
-    };
-
-    shellAliases = {
-      ll = "ls -l --color=auto";
-      lt = "ls -ltrh --color=auto";
-      la = "ls -ltrha --color=auto";
-      pkgsearch = "nix search nixpkgs";
-      flup = "nix flake update --commit-lock-file";
-      emacsrescue = "pkill -SIGUSR2 -i emacs"; # then `M-x toggle-debug-on-quit`
-    };
-
-    oh-my-zsh = {
-      enable = true;
-      plugins = [ "git" ];
-      theme = "robbyrussell";
-    };
-  };
-}