about summary refs log tree commit diff
path: root/nix/profiles/home-manager/shell.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-08 14:59:03 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-08 15:36:32 -0800
commit48ea2837adff1483d6d5e8dd6f65611914ddda88 (patch)
tree8adb236371b1b3db63d450bb98b583b5d0f67cc6 /nix/profiles/home-manager/shell.nix
parentrefactor overall configuration (diff)
downloadworld-48ea2837adff1483d6d5e8dd6f65611914ddda88.tar.gz
more refactoring
Diffstat (limited to '')
-rw-r--r--nix/profiles/home-manager/shell.nix112
1 files changed, 0 insertions, 112 deletions
diff --git a/nix/profiles/home-manager/shell.nix b/nix/profiles/home-manager/shell.nix
deleted file mode 100644
index bfeeb09..0000000
--- a/nix/profiles/home-manager/shell.nix
+++ /dev/null
@@ -1,112 +0,0 @@
-{ pkgs, config, ... }: {
-
-  home.packages = with pkgs; [
-    # shell utils
-    coreutils
-    direnv
-    dust
-    procs
-    ripgrep
-    tree
-    wget
-
-    # network
-    bandwhich
-
-    # data manipulation
-    jless
-    jq
-    yq
-
-    # encryption
-    age
-
-    # media
-    # mpv - TODO: this is currently broken
-    ffmpeg
-
-    # dicts
-    aspell
-    aspellDicts.en
-    aspellDicts.en-computers
-    aspellDicts.en-science
-
-    # nix related
-    nil
-    nix-direnv
-    nixd
-    nixfmt-classic
-    nixpkgs-fmt
-    nil # nix lsp
-  ];
-
-  xdg = {
-    configFile = {
-      "aspell/config".text = ''
-        local-data-dir ${pkgs.aspell}/lib/aspell
-        data-dir ${pkgs.aspellDicts.en}/lib/aspell
-        personal ${config.xdg.configHome}/aspell/en_US.personal
-        repl ${config.xdg.configHome}/aspell/en_US.repl
-      '';
-    };
-  };
-
-  home.sessionVariables = {
-    EDITOR = "emacsclient -a=";
-    VISUAL = "emacsclient -a=";
-    LESS = "-FRSXM";
-    LESSCHARSET = "utf-8";
-    PAGER = "less";
-    ASPELL_CONF = "conf ${config.xdg.configHome}/aspell/config;";
-    # for some reason, if I don't set this, zsh is picked up and mess up stuff.
-    SHELL = "${pkgs.fish}/bin/fish";
-    # stop bothering me with brew messages
-    HOMEBREW_NO_AUTO_UPDATE = 1;
-  };
-
-  # an alternative to ls
-  programs.eza = {
-    enable = true;
-    icons = "never";
-    enableFishIntegration = false;
-    extraOptions = [
-      "--group-directories-first"
-      "--no-quotes"
-      "--git-ignore"
-      "--icons=never"
-    ];
-  };
-
-  # an alternative to find
-  programs.fd = {
-    enable = true;
-    hidden = true;
-    ignores = [ ".git/" ];
-  };
-
-  programs.direnv = {
-    enable = true;
-    nix-direnv.enable = true;
-    enableZshIntegration = true;
-    config = {
-      global.disable_stdin = true;
-      global.strict_env = true;
-    };
-  };
-
-  programs.fish = {
-    enable = true;
-    interactiveShellInit = ''
-      set fish_greeting ""
-    '';
-
-    shellAbbrs = { ncg = "nix-collect-garbage -d"; };
-    shellAliases = {
-      c = "clear";
-      ls = "eza -l -L=1 --git --color=always --group-directories-first";
-      la = "eza -la --git --color=always --group-directories-first";
-      ll = "eza -la -L=1 --git --color=always --group-directories-first";
-      lt = "eza -aT -L=2 --git --color=always --group-directories-first";
-    };
-  };
-}