about summary refs log tree commit diff
path: root/nix/profiles/home-manager/dev.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-08 14:59:03 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-08 15:36:32 -0800
commit48ea2837adff1483d6d5e8dd6f65611914ddda88 (patch)
tree8adb236371b1b3db63d450bb98b583b5d0f67cc6 /nix/profiles/home-manager/dev.nix
parentrefactor overall configuration (diff)
downloadworld-48ea2837adff1483d6d5e8dd6f65611914ddda88.tar.gz
more refactoring
Diffstat (limited to '')
-rw-r--r--nix/profiles/home-manager/dev.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/nix/profiles/home-manager/dev.nix b/nix/profiles/home-manager/dev.nix
deleted file mode 100644
index 02eb566..0000000
--- a/nix/profiles/home-manager/dev.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ pkgs, config, ... }: {
-
-  programs.go = {
-    enable = true;
-    goPath = ".local/share/pkg.go";
-    goBin = ".local/bin.go";
-    goPrivate = [ "github.rbx.com/*" "github.com/fcuny/*" "git.fcuny.net/*" ];
-  };
-
-  home.packages = with pkgs; [
-    # go
-    go-tools
-    golangci-lint
-    gopls
-    delve
-
-    # docker
-    dive # explore layers in docker images
-
-    # shell
-    shellcheck
-
-    # ops
-    google-cloud-sdk
-    kubectl
-    tfswitch
-  ];
-
-  home.sessionPath = [ config.home.sessionVariables.GOBIN ];
-
-  home.sessionVariables = with config.xdg; {
-    IPYTHONDIR = "${cacheHome}/ipython";
-    PIP_LOG = "${cacheHome}/pip/pip.log";
-    PYLINTHOME = "${cacheHome}/pylint";
-    PYTHON_EGG_CACHE = "${cacheHome}/python-eggs";
-    MYPY_CACHE_DIR = "${cacheHome}/mypy";
-  };
-}