about summary refs log tree commit diff
path: root/nix/mkSystem.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-03-18 11:58:35 -0700
committerFranck Cuny <franck@fcuny.net>2023-04-03 17:53:02 -0700
commitc5a78751f96587bf4a3704143ac81598ee6c3e5b (patch)
treedaf41e9b05ade02118eaa08aabf9bac771e12c71 /nix/mkSystem.nix
parentflake: fix URL for sendsms (diff)
downloadworld-c5a78751f96587bf4a3704143ac81598ee6c3e5b.tar.gz
hosts/carmel: reconfigure the host as a router
I'm not using it as a desktop, and the current router is getting old and
will likely fail in the near future. It's also a debian machine
configured manually, so let's reconfigure carmel as our new router.

There are three NICs in the host: 2 are 10Gb and one is 1Gb. The 1Gb
will be used as the upstream interface, and one of the 10Gb will be for
the LAN.

There are 2 VLANs to configure: one for IoT devices and one for guest.
Diffstat (limited to '')
-rw-r--r--nix/mkSystem.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nix/mkSystem.nix b/nix/mkSystem.nix
index 1cb450f..9b5fcd5 100644
--- a/nix/mkSystem.nix
+++ b/nix/mkSystem.nix
@@ -5,7 +5,7 @@ let
 in
 inputs.nixpkgs.lib.nixosSystem {
   inherit system;
-  specialArgs = { inherit inputs system hostname; };
+  specialArgs = { inherit inputs system hostname self; };
   modules = [
     "${self}/modules"
     "${self}/hosts/${hostname}"