about summary refs log tree commit diff
path: root/nix/mkSystem.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-08-22 19:12:06 -0700
committerFranck Cuny <franck@fcuny.net>2022-08-22 19:12:06 -0700
commitb919a1592580af487eade8eb00b8e459810c52fd (patch)
treed4720d5d6a29944d341d638015f2c5f87470bab5 /nix/mkSystem.nix
parentref(modules/backup): only keep 4 weeks worth of backups (diff)
downloadworld-b919a1592580af487eade8eb00b8e459810c52fd.tar.gz
feat(rust): add an overlay to install rust
Installing the rust overlay to get the various tools installed. This is
done by a new module for home-manager, and is installed only on my
laptop at the moment.

Change-Id: I80c1633ca04da82f4321a0687a05d1df7c523702
Diffstat (limited to '')
-rw-r--r--nix/mkSystem.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nix/mkSystem.nix b/nix/mkSystem.nix
index a411a98..1f7ccaf 100644
--- a/nix/mkSystem.nix
+++ b/nix/mkSystem.nix
@@ -14,6 +14,7 @@ inputs.nixpkgs.lib.nixosSystem {
         overlays = [
           inputs.emacs-overlay.overlay
           inputs.nur.overlay
+          inputs.rust.overlay
           (final: prev: {
             tools = import "${self}/tools" { pkgs = prev; };
           })