about summary refs log tree commit diff
path: root/nix/machines/vm-synology/hardware.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /nix/machines/vm-synology/hardware.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to '')
-rw-r--r--nix/machines/vm-synology/hardware.nix15
1 files changed, 12 insertions, 3 deletions
diff --git a/nix/machines/vm-synology/hardware.nix b/nix/machines/vm-synology/hardware.nix
index 5511e98..cd1d5e7 100644
--- a/nix/machines/vm-synology/hardware.nix
+++ b/nix/machines/vm-synology/hardware.nix
@@ -6,8 +6,14 @@
 {
   imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
 
-  boot.initrd.availableKernelModules =
-    [ "ata_piix" "uhci_hcd" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
+  boot.initrd.availableKernelModules = [
+    "ata_piix"
+    "uhci_hcd"
+    "virtio_pci"
+    "virtio_scsi"
+    "sd_mod"
+    "sr_mod"
+  ];
   boot.initrd.kernelModules = [ ];
   boot.kernelModules = [ "kvm-amd" ];
   boot.extraModulePackages = [ ];
@@ -20,7 +26,10 @@
   fileSystems."/boot" = {
     device = "/dev/disk/by-label/boot";
     fsType = "vfat";
-    options = [ "fmask=0022" "dmask=0022" ];
+    options = [
+      "fmask=0022"
+      "dmask=0022"
+    ];
   };
 
   swapDevices = [ ];