about summary refs log tree commit diff
path: root/nix/machines/vm-aarch64/hardware.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /nix/machines/vm-aarch64/hardware.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to '')
-rw-r--r--nix/machines/vm-aarch64/hardware.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/nix/machines/vm-aarch64/hardware.nix b/nix/machines/vm-aarch64/hardware.nix
index 084cc74..67dc249 100644
--- a/nix/machines/vm-aarch64/hardware.nix
+++ b/nix/machines/vm-aarch64/hardware.nix
@@ -1,10 +1,14 @@
 # Do not modify this file!  It was generated by ‘nixos-generate-config’
 # and may be overwritten by future invocations.  Please make changes
 # to /etc/nixos/configuration.nix instead.
-{ lib, modulesPath, ... }: {
+{ lib, modulesPath, ... }:
+{
   imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
 
-  boot.initrd.availableKernelModules = [ "xhci_pci" "sr_mod" ];
+  boot.initrd.availableKernelModules = [
+    "xhci_pci"
+    "sr_mod"
+  ];
   boot.initrd.kernelModules = [ ];
   boot.kernelModules = [ ];
   boot.extraModulePackages = [ ];
@@ -17,7 +21,10 @@
   fileSystems."/boot" = {
     device = "/dev/disk/by-label/boot";
     fsType = "vfat";
-    options = [ "fmask=0022" "dmask=0022" ];
+    options = [
+      "fmask=0022"
+      "dmask=0022"
+    ];
   };
 
   swapDevices = [ ];