about summary refs log tree commit diff
path: root/nix/machines/vm-aarch64.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-08 13:58:02 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-08 15:35:17 -0800
commit52ac07299f2342afe0c309f3b8be3ea05c7549ff (patch)
treebad76e67ba8a1f9301eb87a8c5e66c8a5a260e76 /nix/machines/vm-aarch64.nix
parentadd targets to create virtual machines (diff)
downloadworld-52ac07299f2342afe0c309f3b8be3ea05c7549ff.tar.gz
refactor overall configuration
The configuration of the various hosts and home-manager was becoming a
bit complex for no valid reasons. Try to simplify this a bit.
Diffstat (limited to '')
-rw-r--r--nix/machines/vm-aarch64.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nix/machines/vm-aarch64.nix b/nix/machines/vm-aarch64.nix
new file mode 100644
index 0000000..8e84ed5
--- /dev/null
+++ b/nix/machines/vm-aarch64.nix
@@ -0,0 +1,16 @@
+{ ... }: {
+  imports = [ ./hardware/vm-aarch64-utm.nix ./vm-shared.nix ];
+
+  # Interface is this on my M1
+  networking.interfaces.enp0s10.useDHCP = true;
+
+  # Qemu
+  services.spice-vdagentd.enable = true;
+
+  # For now, we need this since hardware acceleration does not work.
+  environment.variables.LIBGL_ALWAYS_SOFTWARE = "1";
+
+  # Lots of stuff that uses aarch64 that claims doesn't work, but actually works.
+  nixpkgs.config.allowUnfree = true;
+  nixpkgs.config.allowUnsupportedSystem = true;
+}