about summary refs log tree commit diff
path: root/nix/lib/overlays.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /nix/lib/overlays.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to '')
-rw-r--r--nix/lib/overlays.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/nix/lib/overlays.nix b/nix/lib/overlays.nix
index 531c725..7b338c6 100644
--- a/nix/lib/overlays.nix
+++ b/nix/lib/overlays.nix
@@ -1,5 +1,9 @@
-let path = ../../overlays;
-in with builtins;
-map (n: import (path + ("/" + n))) (filter (n:
-  match ".*\\.nix" n != null || pathExists (path + ("/" + n + "/default.nix")))
-  (attrNames (readDir path)))
+let
+  path = ../../overlays;
+in
+with builtins;
+map (n: import (path + ("/" + n))) (
+  filter (n: match ".*\\.nix" n != null || pathExists (path + ("/" + n + "/default.nix"))) (
+    attrNames (readDir path)
+  )
+)