about summary refs log tree commit diff
path: root/nix/hosts/nixos/wildcat/networking.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-08 15:50:27 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-08 15:50:27 -0800
commitac0ab13688225fc17246ca0fc86c00c02f04105e (patch)
tree63682137f69c0591a7bf2e94e3991aba4db3bd9b /nix/hosts/nixos/wildcat/networking.nix
parentfix conflict (diff)
downloadworld-ac0ab13688225fc17246ca0fc86c00c02f04105e.tar.gz
move the configuration for hetzner under machines
Diffstat (limited to '')
-rw-r--r--nix/hosts/nixos/wildcat/networking.nix51
1 files changed, 0 insertions, 51 deletions
diff --git a/nix/hosts/nixos/wildcat/networking.nix b/nix/hosts/nixos/wildcat/networking.nix
deleted file mode 100644
index c0b4bd0..0000000
--- a/nix/hosts/nixos/wildcat/networking.nix
+++ /dev/null
@@ -1,51 +0,0 @@
-{ lib, ... }: {
-  # This file was populated at runtime with the networking
-  # details gathered from the active system.
-  networking = {
-    nameservers =
-      [ "2a01:4ff:ff00::add:2" "2a01:4ff:ff00::add:1" "185.12.64.1" ];
-    defaultGateway = "172.31.1.1";
-    defaultGateway6 = {
-      address = "fe80::1";
-      interface = "eth0";
-    };
-    dhcpcd.enable = false;
-    usePredictableInterfaceNames = lib.mkForce false;
-    interfaces = {
-      eth0 = {
-        ipv4.addresses = [{
-          address = "5.78.87.68";
-          prefixLength = 32;
-        }];
-        ipv6.addresses = [
-          {
-            address = "2a01:4ff:1f0:d1a3::1";
-            prefixLength = 64;
-          }
-          {
-            address = "fe80::9400:3ff:fe98:d6dc";
-            prefixLength = 64;
-          }
-        ];
-        ipv4.routes = [{
-          address = "172.31.1.1";
-          prefixLength = 32;
-        }];
-        ipv6.routes = [{
-          address = "fe80::1";
-          prefixLength = 128;
-        }];
-      };
-
-    };
-    firewall.allowedTCPPorts = [
-      22 # ssh
-      80 # nginx
-      443 # nginx
-    ];
-  };
-  services.udev.extraRules = ''
-    ATTR{address}=="96:00:03:98:d6:dc", NAME="eth0"
-
-  '';
-}