about summary refs log tree commit diff
path: root/nix/flake/packages.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-03-06 06:19:29 -0800
committerFranck Cuny <franck@fcuny.net>2024-03-06 06:19:29 -0800
commitc0b9780594366f9256b6f46ac0955d70281c38b6 (patch)
tree2e717c3107f010af8c8afcb06cf7866e92b52f4e /nix/flake/packages.nix
parentadd configuration for my work machine (diff)
downloadworld-c0b9780594366f9256b6f46ac0955d70281c38b6.tar.gz
install my own scripts
This is the first step to re-enable installing custom scripts. The next
step will be to rename `tools` to `packages`, and then if needed I will
be able to support overlays.
Diffstat (limited to '')
-rw-r--r--nix/flake/packages.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nix/flake/packages.nix b/nix/flake/packages.nix
new file mode 100644
index 0000000..38e243f
--- /dev/null
+++ b/nix/flake/packages.nix
@@ -0,0 +1,16 @@
+{ inputs, ... }: {
+  imports = [
+    inputs.flake-parts.flakeModules.easyOverlay
+  ];
+
+  perSystem = { config, pkgs, ... }: {
+    overlayAttrs = {
+      inherit (config.packages)
+        seqstat;
+    };
+
+    packages = {
+      seqstat = pkgs.callPackage ../../tools/seqstat { };
+    };
+  };
+}