about summary refs log tree commit diff
path: root/modules/systems/nix.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-08 09:22:53 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-08 09:22:53 -0800
commitf41c1898ebb20fe9cbe6708e6847a3e60973747d (patch)
tree71646fe8cf56427bee4760ad7ff664b7aa56bd45 /modules/systems/nix.nix
parentmodules: start desktop configuration (diff)
downloadworld-f41c1898ebb20fe9cbe6708e6847a3e60973747d.tar.gz
systems: default configuration for all systems
Diffstat (limited to '')
-rw-r--r--modules/systems/nix.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/systems/nix.nix b/modules/systems/nix.nix
new file mode 100644
index 0000000..4b97121
--- /dev/null
+++ b/modules/systems/nix.nix
@@ -0,0 +1,17 @@
+{ lib, pkgs, ... }:
+
+{
+  nix.extraOptions = ''
+    experimental-features = nix-command
+  '';
+
+  nix.settings = {
+    auto-optimise-store = true;
+    trusted-users = [ "root" "@wheel" ];
+  };
+
+  nix.gc = {
+    automatic = true;
+    options = "--delete-older-than 14d";
+  };
+}