about summary refs log tree commit diff
path: root/modules/services/tlp/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-01 19:42:25 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-01 19:42:25 -0700
commitf6988202567bc5550d412f5e70125cd5e049a501 (patch)
tree1bd202120a78c0a9b938d1d7fd657bce1f9766ce /modules/services/tlp/default.nix
parentprofiles/workstation: reduce the number of moving parts (diff)
downloadworld-f6988202567bc5550d412f5e70125cd5e049a501.tar.gz
profiles/laptop: consolidate services related to laptop
Diffstat (limited to '')
-rw-r--r--modules/services/tlp/default.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/modules/services/tlp/default.nix b/modules/services/tlp/default.nix
deleted file mode 100644
index ac083d8..0000000
--- a/modules/services/tlp/default.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-# TLP power management
-{ config, lib, ... }:
-let cfg = config.my.services.tlp;
-in
-{
-  options.my.services.tlp = {
-    enable = lib.mkEnableOption "TLP power management configuration";
-  };
-
-  config = lib.mkIf cfg.enable {
-    services.tlp = {
-      enable = true;
-
-      settings = {
-        # Set CPU scaling aggressively when power is not an issue
-        CPU_SCALING_GOVERNOR_ON_AC = "schedutil";
-        CPU_SCALING_GOVERNOR_ON_BAT = "schedutil";
-
-        # Keep charge between 60% and 80% to preserve battery life
-        START_CHARGE_THRESH_BAT0 = 60;
-        STOP_CHARGE_THRESH_BAT0 = 80;
-      };
-    };
-  };
-}