about summary refs log tree commit diff
path: root/modules/services/rclone/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-04-30 11:34:02 -0700
committerFranck Cuny <franck@fcuny.net>2023-04-30 14:40:30 -0700
commit5a5b98210b56a297e0e227f0895a9778f2e22147 (patch)
tree54da638518953b47b5ca9827b6f0eacf1c94dd82 /modules/services/rclone/default.nix
parentmodules/security: move ssh configuration to a dedicated module (diff)
downloadworld-5a5b98210b56a297e0e227f0895a9778f2e22147.tar.gz
modules/rclone: delete the module and cleanup
I'm not using rclone anymore and I'm not storing the backups to GCS
buckets either.
Diffstat (limited to '')
-rw-r--r--modules/services/rclone/default.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/modules/services/rclone/default.nix b/modules/services/rclone/default.nix
deleted file mode 100644
index cbef0c3..0000000
--- a/modules/services/rclone/default.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ config, pkgs, lib, ... }:
-let
-  cfg = config.my.services.rclone;
-  secrets = config.age.secrets;
-in
-{
-  options.my.services.rclone = with lib; {
-    enable = mkEnableOption "rclone backup service";
-  };
-
-  config = lib.mkIf cfg.enable {
-    systemd = {
-      packages = [ pkgs.rclone ];
-      timers.rclone-sync = {
-        description = "synchronize restic repository to GCS";
-        wantedBy = [ "timers.target" ];
-        partOf = [ "rclone-sync.service" ];
-        timerConfig = { OnCalendar = "02:00"; };
-      };
-      services.rclone-sync = {
-        description = "synchronize restic repository to GCS";
-        serviceConfig =
-          let
-            rcloneOptions = "--config=${
-              secrets."rclone/config.ini".path
-            } --gcs-service-account-file=${
-              secrets."rclone/gcs_service_account.json".path
-            } --fast-list --verbose";
-          in
-          {
-            Type = "oneshot";
-            ExecStart = [
-              "${pkgs.rclone}/bin/rclone ${rcloneOptions} sync /data/slow/backups/systems gbackup:fcuny-backups-systems"
-              "${pkgs.rclone}/bin/rclone ${rcloneOptions} sync /data/slow/backups/users gbackup:fcuny-backups-users"
-            ];
-          };
-      };
-    };
-  };
-}