about summary refs log tree commit diff
path: root/modules/services/pcscd/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-02-12 08:21:03 -0800
committerFranck Cuny <franck@fcuny.net>2023-02-20 13:33:00 -0800
commitd5b3fb1e553f80691552747c76b53c3e7596f41c (patch)
treefd112053650094b795c90848a1b5bb1266abd4f8 /modules/services/pcscd/default.nix
parentfeat(home/age): install tooling related to age and yubikeys (diff)
downloadworld-d5b3fb1e553f80691552747c76b53c3e7596f41c.tar.gz
feat(modules/pcscd): install the pcscd daemon
This is to use the yubikeys correctly
Diffstat (limited to '')
-rw-r--r--modules/services/pcscd/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/services/pcscd/default.nix b/modules/services/pcscd/default.nix
new file mode 100644
index 0000000..84a588e
--- /dev/null
+++ b/modules/services/pcscd/default.nix
@@ -0,0 +1,11 @@
+# PCSCD management
+{ config, lib, ... }:
+let cfg = config.my.services.pcscd;
+in
+{
+  options.my.services.pcscd = {
+    enable = lib.mkEnableOption "pcscd configuration (for yubikeys)";
+  };
+
+  config = lib.mkIf cfg.enable { services.pcscd.enable = true; };
+}