about summary refs log tree commit diff
path: root/modules/programs/sway/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-06 11:14:22 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-06 11:14:22 -0700
commitff2547f3ed61308614ad1fe832a6ea741a12b6f9 (patch)
treed8d9b086dfb67039795d640e349d017f79c7a9ce /modules/programs/sway/default.nix
parentprofiles/gtk: configure dark mode properly (diff)
downloadworld-ff2547f3ed61308614ad1fe832a6ea741a12b6f9.tar.gz
profiles/workstation: move sway to the workstation profile
Diffstat (limited to '')
-rw-r--r--modules/programs/sway/default.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/modules/programs/sway/default.nix b/modules/programs/sway/default.nix
deleted file mode 100644
index afb3204..0000000
--- a/modules/programs/sway/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ pkgs, config, lib, ... }:
-let cfg = config.my.programs.sway;
-in
-{
-  options.my.programs.sway = with lib; {
-    enable = mkEnableOption "sway configuration";
-  };
-
-  config = lib.mkIf cfg.enable {
-    programs.sway = {
-      enable = true;
-      wrapperFeatures.gtk = true;
-      extraPackages = with pkgs; [
-        brightnessctl
-        polkit_gnome
-        xsettingsd
-        swaylock
-        swayidle
-        wl-clipboard
-      ];
-      extraSessionCommands = ''
-        export MOZ_ENABLE_WAYLAND=1
-      '';
-    };
-  };
-}