about summary refs log tree commit diff
path: root/hosts/tahoe/services.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-24 13:46:18 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-24 13:46:18 -0700
commit94f8172f0f5a6d5568b5204d88c5d45e77a20f69 (patch)
treea4a11722232dc2e015e2c32eeebf12be4fd5f53f /hosts/tahoe/services.nix
parenttmux: start windows at 1 (diff)
downloadworld-94f8172f0f5a6d5568b5204d88c5d45e77a20f69.tar.gz
backups: do backups for the laptop
From the laptop I only backup /home/fcuny, as the rest should be
straightforward to rebuild with nix.

I run that backup as my own user, since I need my ssh key to use the
remote repository (which is on the NAS). I also need a new secret for
it (I might have been able to use `pass' for this, but well, that's easy
enough).

For the NAS, I update the list of directories to backup to include home,
this will be on the systems backup.
Diffstat (limited to '')
-rw-r--r--hosts/tahoe/services.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/hosts/tahoe/services.nix b/hosts/tahoe/services.nix
index 7de94f6..9bd7162 100644
--- a/hosts/tahoe/services.nix
+++ b/hosts/tahoe/services.nix
@@ -43,7 +43,8 @@ in {
       repository = "/data/slow/backups/systems";
       timerConfig = { OnCalendar = "00:15"; };
       passwordFile = secrets."restic/repo-systems".path;
-      paths = [ "/data/fast/music" "/data/fast/photos" "/data/fast/videos" ];
+      paths =
+        [ "/home" "/data/fast/music" "/data/fast/photos" "/data/fast/videos" ];
     };
   };
 }