about summary refs log tree commit diff
path: root/hosts/tahoe/services.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-11 07:09:07 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-11 07:09:07 -0700
commit293006546940d2b8dc69e2920c3f18da07ade02f (patch)
tree0934dd7ba02583815743f1d5b6623a7237e02dbb /hosts/tahoe/services.nix
parenthome: enable ssh config on trusted hosts (diff)
downloadworld-293006546940d2b8dc69e2920c3f18da07ade02f.tar.gz
tahoe: fix backup configuration
Diffstat (limited to '')
-rw-r--r--hosts/tahoe/services.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/hosts/tahoe/services.nix b/hosts/tahoe/services.nix
index 9bd9a35..75a6ee2 100644
--- a/hosts/tahoe/services.nix
+++ b/hosts/tahoe/services.nix
@@ -1,4 +1,4 @@
-{ ... }:
+{ config, ... }:
 let secrets = config.age.secrets;
 in {
   my.services = {
@@ -22,8 +22,9 @@ in {
     transmission = { enable = true; };
     metrics-exporter = { enable = true; };
     backup = {
+      enable = true;
       repository = "/data/slow/backups/systems";
-      timerConfig = { oncalendar = "00:15"; };
+      timerConfig = { OnCalendar = "00:15"; };
       passwordFile = secrets."restic/repo-systems".path;
       paths = [ "/data/fast/music" "/data/fast/photos" "/data/fast/videos" ];
     };