about summary refs log tree commit diff
path: root/hosts/tahoe/hardware.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-01-10 08:38:32 -0800
committerFranck Cuny <franck@fcuny.net>2023-01-10 08:41:28 -0800
commitc775fe987389dcbdb19b2a69eb06df46d20df92a (patch)
tree893a021287239759161e19365178d68974155cd3 /hosts/tahoe/hardware.nix
parentfix(modules/unifi): pin the package for mongodb (diff)
downloadworld-c775fe987389dcbdb19b2a69eb06df46d20df92a.tar.gz
fix(hosts/tahoe): workaround md raid boot uuid issue in 22.11
Due to md device uuid availability issue in initrd.
Refs:
- https://github.com/NixOS/nixpkgs/issues/196800
- https://github.com/NixOS/nixpkgs/issues/199551
Diffstat (limited to '')
-rw-r--r--hosts/tahoe/hardware.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/hosts/tahoe/hardware.nix b/hosts/tahoe/hardware.nix
index ab08490..f0fbc2d 100644
--- a/hosts/tahoe/hardware.nix
+++ b/hosts/tahoe/hardware.nix
@@ -43,7 +43,7 @@
   };
 
   boot.initrd.luks.devices."raid-fast".device =
-    "/dev/disk/by-uuid/66c58a92-45fe-4b03-9be0-214ff67c177c";
+    "/dev/disk/by-id/md-name-nixos:fast";
 
   fileSystems."/data/slow" = {
     device = "/dev/disk/by-uuid/0f16db51-0ee7-48d8-9e48-653b85ecbf0a";
@@ -51,7 +51,7 @@
   };
 
   boot.initrd.luks.devices."raid-slow".device =
-    "/dev/disk/by-uuid/d8b21267-d457-4522-91d9-5481b44dd0a5";
+    "/dev/disk/by-id/md-name-nixos:slow";
 
   swapDevices =
     [{ device = "/dev/disk/by-uuid/0f54b5ab-4fca-4c5a-a9eb-622553145163"; }];