about summary refs log tree commit diff
path: root/hosts/common/nix.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-03-11 17:15:43 -0700
committerFranck Cuny <franck@fcuny.net>2024-03-11 17:15:43 -0700
commit63637f993f7d15cc8750d519e210a7d7c22a1efa (patch)
tree155caba0021e551a50baad53be190256d025012f /hosts/common/nix.nix
parentmark nix 2.16.2 as insecure (diff)
downloadworld-63637f993f7d15cc8750d519e210a7d7c22a1efa.tar.gz
reorganize common files for hosts
Move the common configuration for nix to its own file.
Diffstat (limited to '')
-rw-r--r--hosts/common/nix.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/hosts/common/nix.nix b/hosts/common/nix.nix
new file mode 100644
index 0000000..c828a16
--- /dev/null
+++ b/hosts/common/nix.nix
@@ -0,0 +1,24 @@
+{ pkgs, ... }: {
+  nix = {
+    package = pkgs.nixFlakes;
+
+    gc = {
+      user = "root";
+      automatic = true;
+      interval = { Weekday = 0; Hour = 2; Minute = 0; };
+      options = "--delete-older-than 30d";
+    };
+
+    settings = {
+      trusted-users = [ "@admin" "fcuny" ];
+      experimental-features = [ "nix-command" "flakes" ];
+    };
+  };
+
+  nixpkgs.config = {
+    allowUnfree = true;
+    permittedInsecurePackages = [
+      "nix-2.16.2" # FIXME https://github.com/nix-community/nixd/issues/357
+    ];
+  };
+}