about summary refs log tree commit diff
path: root/hosts/common/nas.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-03-06 08:09:06 -0800
committerFranck Cuny <franck@fcuny.net>2022-03-06 08:09:06 -0800
commit86a82a5e4eaf1db45e72182e8dc14ca85e9988cc (patch)
treed7160df4509c5227e2fd247e8e9f78cdb77bdbd5 /hosts/common/nas.nix
parentbackups: unit to run maintenance on my backups (diff)
downloadworld-86a82a5e4eaf1db45e72182e8dc14ca85e9988cc.tar.gz
traefik: initial configuration
I want to run traefik on the NAS, so I can reach grafana and other
future services running on that host.

To manage TLS, we use let's encrypt with a DNS challenge. For this to
work we need a service account configuration, that is encrypted with
age.
Diffstat (limited to '')
-rw-r--r--hosts/common/nas.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/hosts/common/nas.nix b/hosts/common/nas.nix
index 92b0d3f..a45cab4 100644
--- a/hosts/common/nas.nix
+++ b/hosts/common/nas.nix
@@ -7,5 +7,17 @@
     ./server/prometheus.nix
     ./server/grafana.nix
     ./server/backups/users.nix
+    ./server/traefik.nix
   ];
+
+  age.secrets.traefik-gcp-sa = {
+    file = ../secrets/traefik/gcp_sa.age;
+    mode = "0440";
+    owner = "0";
+  };
+
+  traefik = {
+    gcpKeyFile = "/run/agenix/gcp_sa";
+    gcpProjectName = "fcuny-homelab";
+  };
 }