about summary refs log tree commit diff
path: root/hosts/aptos/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-03-12 19:43:29 -0800
committerFranck Cuny <franck@fcuny.net>2022-03-12 19:43:29 -0800
commit49bf86357926d961ce2090e84accdb48de17a1b5 (patch)
treef162b2ba47ceffb7040d43c6b0be94cf14636cfe /hosts/aptos/default.nix
parentrclone: add users backup (diff)
downloadworld-49bf86357926d961ce2090e84accdb48de17a1b5.tar.gz
containers: enable dockerd and containerd on aptos
Diffstat (limited to '')
-rw-r--r--hosts/aptos/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/hosts/aptos/default.nix b/hosts/aptos/default.nix
index 24f823e..f3ed313 100644
--- a/hosts/aptos/default.nix
+++ b/hosts/aptos/default.nix
@@ -10,6 +10,17 @@
 
   boot = { initrd = { luks.devices."system".allowDiscards = true; }; };
 
+  virtualisation.docker = { enable = true; };
+
+  virtualisation.containerd = {
+    enable = true;
+    settings = {
+      plugins."io.containerd.grpc.v1.cri" = {
+        containerd.snapshotter = "overlayfs";
+      };
+    };
+  };
+
   # Use systemd-networkd for networking
   systemd.network = {
     enable = true;