about summary refs log tree commit diff
path: root/home/yubikey/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
commit43da9edb4598eef509c481ae0b305384418c45de (patch)
treea0ad614c90102757143e026e4fe1806431a3dbf4 /home/yubikey/default.nix
parentprofiles/default: users are immutable (diff)
downloadworld-43da9edb4598eef509c481ae0b305384418c45de.tar.gz
home/profiles: move (almost) all modules to profiles
This is a major refactor, similar to what was done for the hosts, but in
a single commit.
Diffstat (limited to '')
-rw-r--r--home/yubikey/default.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/home/yubikey/default.nix b/home/yubikey/default.nix
deleted file mode 100644
index d4b73d5..0000000
--- a/home/yubikey/default.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ pkgs, config, lib, ... }:
-let cfg = config.my.home.yubikey;
-in
-{
-  options.my.home.yubikey = with lib; {
-    enable = mkEnableOption "yubikey tooling";
-  };
-
-  config = lib.mkIf cfg.enable {
-    home.packages = with pkgs; [ yubikey-manager yubikey-touch-detector ];
-
-    systemd.user.sockets.yubikey-touch-detector = {
-      Unit.Description = "Unix socket activation for YubiKey touch detector service";
-      Socket = {
-        ListenStream = "%t/yubikey-touch-detector.socket";
-        RemoveOnStop = true;
-      };
-      Install.WantedBy = [ "sockets.target" ];
-    };
-
-    systemd.user.services.yubikey-touch-detector = {
-      Unit = {
-        Description = "Detects when your YubiKey is waiting for a touch";
-        Requires = "yubikey-touch-detector.socket";
-      };
-      Service = {
-        ExecStart = "${pkgs.yubikey-touch-detector}/bin/yubikey-touch-detector --libnotify";
-        EnvironmentFile = "-%E/yubikey-touch-detector/service.conf";
-      };
-      Install = {
-        Also = "yubikey-touch-detector.socket";
-        WantedBy = [ "default.target" ];
-      };
-    };
-  };
-}