about summary refs log tree commit diff
path: root/home/wm/wofi/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-08 08:30:17 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-08 08:30:17 -0700
commit2aa3e62136109c5c4762e951525d68aff3e1ac5a (patch)
tree0f508cad82717ac70c7da5fd402c9555ce9166d1 /home/wm/wofi/default.nix
parenthome: fix for yt-dlp configuration (diff)
downloadworld-2aa3e62136109c5c4762e951525d68aff3e1ac5a.tar.gz
home: add more configurations for home-manager
Diffstat (limited to '')
-rw-r--r--home/wm/wofi/default.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/home/wm/wofi/default.nix b/home/wm/wofi/default.nix
new file mode 100644
index 0000000..9ccb4be
--- /dev/null
+++ b/home/wm/wofi/default.nix
@@ -0,0 +1,59 @@
+{ config, lib, pkgs, ... }:
+let isEnabled = config.my.home.wm.windowManager == "sway";
+in {
+  config = lib.mkIf isEnabled {
+    home.packages = with pkgs; [ wofi ];
+    xdg.configFile."wofi/config".text = ''
+      allow_images=true
+      image_size=20px
+      drun-display_generic=true
+      dynamic_lines=true
+    '';
+
+    xdg.configFile."wofi/style.css".text = ''
+      *{
+        font-family: monospace;
+      }
+
+      window {
+        color: #5E81AC;
+        background-color: rgba(27, 27, 28, 0.92);
+        border: 2px solid #75d5ff;
+      }
+
+      #input {
+        margin: 10px 0px;
+        border-radius: 0px;
+        border: none;
+        background: transparent;
+        color: white;
+      }
+
+      #inner-box {
+        background-color: transparent;
+      }
+
+      #outer-box {
+        margin: 0px;
+        padding:5px;
+        background-color: transparent;
+      }
+
+      #text {
+        padding: 5px;
+        color: white;
+      }
+
+      #entry:selected {
+        color: #75d5ff;
+        background-color: transparent;
+        border: 0px;
+      }
+
+      #text:selected {
+        color: #75d5ff;
+        background-color: transparent;
+      }
+    '';
+  };
+}