about summary refs log tree commit diff
path: root/home/shell/zsh/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-19 15:57:45 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-20 14:39:35 -0700
commitb5c428822468b9a2dfb00a673c39e809f4ac0651 (patch)
tree54e2190f9b20ce11827d0d5b10da2a96c135437a /home/shell/zsh/default.nix
parentfeat(tools/seqstat): add a tool to report stats about a sequence (diff)
downloadworld-b5c428822468b9a2dfb00a673c39e809f4ac0651.tar.gz
ref(home/shell): make it easier to share common things between shells
I'm considering trying again fish, and there are a number of things that
should be common between zsh and fish (aliases, environment variables,
...).

Instead of duplicating these settings multiple time, I'm consolidating
the shell configurations under `home/shell`, and I can set the shell I
want to use with `my.home.shell.name`.

The first step is to move the modules for fish and zsh under
`home/shell`, add an interface to pick which one I want to use, and
modify the `host/home.nix` configuration to keep using zsh with the new
interface.

Change-Id: Idb66b1a6fcc11a6eeaf5fd2d32dd3698d2d85bdf
Reviewed-on: https://cl.fcuny.net/c/world/+/455
Tested-by: CI
Reviewed-by: Franck Cuny <franck@fcuny.net>
Diffstat (limited to '')
-rw-r--r--home/shell/zsh/default.nix (renamed from home/zsh/default.nix)8
1 files changed, 2 insertions, 6 deletions
diff --git a/home/zsh/default.nix b/home/shell/zsh/default.nix
index 21dbedd..14ddd6c 100644
--- a/home/zsh/default.nix
+++ b/home/shell/zsh/default.nix
@@ -1,12 +1,8 @@
 { config, pkgs, lib, ... }:
-let cfg = config.my.home.zsh;
+let cfg = config.my.home.shell;
 in
 {
-  options.my.home.zsh = with lib; {
-    enable = mkEnableOption "zsh configuration";
-  };
-
-  config = lib.mkIf cfg.enable {
+  config = lib.mkIf (cfg.name == "zsh") {
     home.packages = with pkgs; [ zsh-completions ];
 
     programs.zsh = {