about summary refs log tree commit diff
path: root/home/shell/fish/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-20 11:41:27 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-20 14:40:02 -0700
commitd5b8363d3d56f99fecbf657542a512e58951547d (patch)
treeaa4a3dc3cc789ed91e9d20d5d6aabe6f37ea5b79 /home/shell/fish/default.nix
parentref(home/shell): make it easier to share common things between shells (diff)
downloadworld-d5b8363d3d56f99fecbf657542a512e58951547d.tar.gz
ref(home/shell): move all shell aliases to a shared configuration
By moving the aliases to a shared module, they can be used between zsh
and fish.

Change-Id: Ifcfe0af3b90825fe3a67bc1796d4cf65a58d3ff2
Reviewed-on: https://cl.fcuny.net/c/world/+/456
Reviewed-by: Franck Cuny <franck@fcuny.net>
Tested-by: CI
Diffstat (limited to '')
-rw-r--r--home/shell/fish/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/home/shell/fish/default.nix b/home/shell/fish/default.nix
index 3a21b24..c81f188 100644
--- a/home/shell/fish/default.nix
+++ b/home/shell/fish/default.nix
@@ -2,11 +2,13 @@
 let
   cfg = config.my.home.shell;
   swayEnabled = config.my.home.wm.windowManager == "sway";
+  aliases = config.my.home.shell.aliases;
 in
 {
   config = lib.mkIf (cfg.name == "fish") {
     programs.fish = {
       enable = true;
+      shellAliases = aliases;
       interactiveShellInit = ''
         set fish_greeting