about summary refs log tree commit diff
path: root/home/scripts/perf-flamegraph.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-16 17:20:22 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-16 17:22:13 -0700
commit9d8c62a6e1f28491377b7000a6505c08630dc48c (patch)
tree046809bcc5a8ccbf58d47c5d2c36d9aa4aed5542 /home/scripts/perf-flamegraph.nix
parentdocs(tools/govanity): update instructions (diff)
downloadworld-9d8c62a6e1f28491377b7000a6505c08630dc48c.tar.gz
ref(scripts): remove the module for scripts
The scripts should be part of other modules. If there's no good place
for them, they should be part of the packages module.

Change-Id: Ic6c678fbe981444848a0ac7015c6c2e450f3b1c1
Reviewed-on: https://cl.fcuny.net/c/world/+/424
Tested-by: CI
Reviewed-by: Franck Cuny <franck@fcuny.net>
Diffstat (limited to '')
-rw-r--r--home/scripts/perf-flamegraph.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/home/scripts/perf-flamegraph.nix b/home/scripts/perf-flamegraph.nix
deleted file mode 100644
index b974e6b..0000000
--- a/home/scripts/perf-flamegraph.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ pkgs, config, ... }:
-let
-  perf-flamegraph-process =
-    pkgs.writeShellScriptBin "perf-flamegraph-process" ''
-      set -euo pipefail
-
-      OUT_DIR="''${HOME}/workspace/tmp/flamegraph"
-      OUT_SVG="''${OUT_DIR}/$(date +%y%m%d-%H%M%S).svg"
-
-      mkdir -p ''${OUT_DIR}
-
-      ${pkgs.linuxPackages.perf}/bin/perf record -g --call-graph dwarf -F max "$@"
-      ${pkgs.linuxPackages.perf}/bin/perf script \
-        | ${pkgs.flamegraph}/bin/stackcollapse-perf.pl \
-        | ${pkgs.flamegraph}/bin/flamegraph.pl > "''${OUT_SVG}"
-    '';
-in
-{
-  config = {
-    home.packages = with pkgs; [ flamegraph perf-flamegraph-process ];
-  };
-}
-