about summary refs log tree commit diff
path: root/home/profiles/zsh.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-16 20:09:27 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-16 20:09:27 -0700
commit354afc1754f0616cd086b1a6f607022155a1f9e3 (patch)
treed79cde08506a4297e749828d8f6662b88f69b5cd /home/profiles/zsh.nix
parenthome/ssh: add rsync.net to the match block (diff)
downloadworld-354afc1754f0616cd086b1a6f607022155a1f9e3.tar.gz
profiles/workstation: stop using dark mode + prezto
Diffstat (limited to '')
-rw-r--r--home/profiles/zsh.nix (renamed from home/profiles/zsh/default.nix)22
1 files changed, 11 insertions, 11 deletions
diff --git a/home/profiles/zsh/default.nix b/home/profiles/zsh.nix
index 38450ab..3da6baa 100644
--- a/home/profiles/zsh/default.nix
+++ b/home/profiles/zsh.nix
@@ -6,16 +6,17 @@
     enable = true;
     dotDir = ".config/zsh";
 
+    defaultKeymap = "emacs";
     enableCompletion = true;
     enableAutosuggestions = true;
 
     history = {
       size = 500000;
       save = 500000;
-      extended = false;
+      extended = true;
       ignoreSpace = true;
       ignoreDups = true;
-      share = false;
+      share = true;
       # see
       # https://github.com/nix-community/home-manager/blob/32a7da69dc53c9eb5ad0675eb7fdc58f7fe35272/modules/programs/zsh.nix#L537
       path = "${config.xdg.dataHome}/zsh/zsh_history";
@@ -38,14 +39,13 @@
       dhcp-leasese = "xdg-open http://192.168.6.1:8067/";
     };
 
-    defaultKeymap = "emacs";
-
-    initExtra = lib.concatMapStrings builtins.readFile [
-      ./completion-style.zsh
-      ./options.zsh
-      ./prompt.zsh
-      ./tmux.zsh
-      ./new-go-project.zsh
-    ];
+    prezto = {
+      enable = true;
+      prompt = { theme = "pure"; };
+      pmodules = [
+        "prompt"
+        "git"
+      ];
+    };
   };
 }