about summary refs log tree commit diff
path: root/home/mpv/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
commit43da9edb4598eef509c481ae0b305384418c45de (patch)
treea0ad614c90102757143e026e4fe1806431a3dbf4 /home/mpv/default.nix
parentprofiles/default: users are immutable (diff)
downloadworld-43da9edb4598eef509c481ae0b305384418c45de.tar.gz
home/profiles: move (almost) all modules to profiles
This is a major refactor, similar to what was done for the hosts, but in
a single commit.
Diffstat (limited to '')
-rw-r--r--home/mpv/default.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/home/mpv/default.nix b/home/mpv/default.nix
deleted file mode 100644
index c2a3a6a..0000000
--- a/home/mpv/default.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ lib, config, pkgs, ... }:
-let cfg = config.my.home.mpv;
-in
-{
-  options.my.home.mpv = with lib; {
-    enable = mkEnableOption "mpv configuration";
-  };
-
-  config = lib.mkIf cfg.enable {
-    programs.mpv = {
-      enable = true;
-      config = {
-        sub-auto = "fuzzy";
-        vo = "gpu";
-        hwdec = "auto-safe";
-        gpu-context = "wayland";
-        audio-display = "no";
-        cache-pause = "no";
-        cache = "yes";
-        mute = "no";
-        osc = "yes";
-        screenshot-directory = "~/documents/screenshots/mpv-screenshots/";
-        screenshot-format = "png";
-      };
-      scripts = lib.attrVals [ "sponsorblock" ] pkgs.mpvScripts;
-    };
-  };
-}