about summary refs log tree commit diff
path: root/home/go/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
commit43da9edb4598eef509c481ae0b305384418c45de (patch)
treea0ad614c90102757143e026e4fe1806431a3dbf4 /home/go/default.nix
parentprofiles/default: users are immutable (diff)
downloadworld-43da9edb4598eef509c481ae0b305384418c45de.tar.gz
home/profiles: move (almost) all modules to profiles
This is a major refactor, similar to what was done for the hosts, but in
a single commit.
Diffstat (limited to '')
-rw-r--r--home/go/default.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/home/go/default.nix b/home/go/default.nix
deleted file mode 100644
index 40c65f0..0000000
--- a/home/go/default.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-{ lib, config, pkgs, ... }:
-let cfg = config.my.home.go;
-in
-{
-  options.my.home.go = with lib; {
-    enable = mkEnableOption "go configuration";
-  };
-
-  config = lib.mkIf cfg.enable {
-    programs.go = {
-      enable = true;
-      goPath = ".local/share/pkg.go";
-      goBin = ".local/bin.go";
-      goPrivate = [ "git.fcuny.net" "golang.fcuny.net" ];
-      package = pkgs.go_1_18;
-    };
-    home.packages = with pkgs; [ gopls go-tools ];
-    home.sessionPath = [ config.home.sessionVariables.GOBIN ];
-  };
-}