about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-03-27 09:16:13 -0700
committerFranck Cuny <franck@fcuny.net>2022-03-27 09:16:13 -0700
commitcdda8b0ac283e2ded2e8c330e85bcc93003177bc (patch)
tree34690b903c9b14098a98b6944612a3655ed8b62f /flake.nix
parentprometheus: stop scraping the NAS (diff)
downloadworld-cdda8b0ac283e2ded2e8c330e85bcc93003177bc.tar.gz
nas: install music-organizer
Diffstat (limited to '')
-rw-r--r--flake.nix21
1 files changed, 16 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 2e58b89..4dbdc8f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -17,6 +17,13 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
+    mytools = {
+      url =
+        "git+https://git.fcuny.net/fcuny/tools.git?ref=fcuny/nix&rev=3ea9c82d551b6f1bf415ced29f572a6372f097d8";
+      inputs.nixpkgs.follows = "nixpkgs";
+      inputs.flake-utils.follows = "utils";
+    };
+
     nur.url = "github:nix-community/NUR";
 
     home-manager = {
@@ -28,8 +35,7 @@
 
   # Output config, or config for NixOS system
   outputs = { ... }@inputs:
-    let
-      lib = import ./lib { inherit inputs; };
+    let lib = import ./lib { inherit inputs; };
     in {
       nixosConfigurations = {
         carmel = lib.mkSystem {
@@ -69,12 +75,17 @@
       let
         pkgs = import inputs.nixpkgs { inherit system; };
         home-manager = inputs.home-manager.defaultPackage."${system}";
-      in
-      {
+      in {
         packages = pkgs // { inherit home-manager; };
 
         devShell = pkgs.mkShell {
-          buildInputs = with pkgs; [ nixUnstable nixfmt rnix-lsp home-manager git ];
+          buildInputs = with pkgs; [
+            nixUnstable
+            nixfmt
+            rnix-lsp
+            home-manager
+            git
+          ];
         };
       });
 }