about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-09-26 17:50:41 -0700
committerFranck Cuny <franck@fcuny.net>2022-09-26 17:50:41 -0700
commit2a7b36213c1b8bc9e03466bd7b99fa96abfecd8f (patch)
tree6dd3fd5db0519e5fdb5e04fd329de16e49dfdd30 /flake.nix
parentfix(flake): call some programs with `nix run .#tools.<name>` (diff)
downloadworld-2a7b36213c1b8bc9e03466bd7b99fa96abfecd8f.tar.gz
feat(naersk): use naersk to build packages with rust
naersk makes it simple to build rust project in nix.

For this to work, `mkSystem` and `mkHomeManagerConfiguration` needs to
pass naersk to  my overlays.

I dropped the support to run the tools with `nix run .#tools...`: I
don't use this in practice and it's not making things simpler.

I dropped `nix-linter` from the check, it's reporting many errors
without helping me to fix them.
Diffstat (limited to '')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 7e8280e..2bfcf2e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,6 +9,8 @@
 
     emacs-overlay.url = "github:nix-community/emacs-overlay";
 
+    naersk.url = "github:nix-community/naersk";
+
     agenix = {
       url = "github:ryantm/agenix";
       inputs.nixpkgs.follows = "nixpkgs";
@@ -62,7 +64,6 @@
           pre-commit-check = inputs.pre-commit-hooks.lib."${system}".run {
             src = ./.;
             hooks = {
-              nix-linter.enable = true;
               nixpkgs-fmt.enable = true;
               terraform-format.enable = true;
               trailing-whitespace = {
@@ -133,7 +134,6 @@
         in
         {
           inherit (inputs.futils.lib) filterPackages flattenTree;
-          tools = import ./tools { inherit pkgs; };
           ops = import ./ops { inherit pkgs; };
           users.fcuny = import ./users/fcuny { inherit pkgs; };
         });