about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-09-18 10:18:38 -0700
committerFranck Cuny <franck@fcuny.net>2022-09-18 10:18:38 -0700
commit280905d327ca572c08d36e758bee9691cf49eb80 (patch)
tree3b9e8d6d380b236a9558292d926b5a61d0baed75 /flake.nix
parentfeat(home/python): add a few more packages (diff)
downloadworld-280905d327ca572c08d36e758bee9691cf49eb80.tar.gz
ref(flake): remove pre-commit for golang
There has to be a nicer way, and I might just completely drop golang
support anyway in this repo.
Diffstat (limited to '')
-rw-r--r--flake.nix35
1 files changed, 1 insertions, 34 deletions
diff --git a/flake.nix b/flake.nix
index d83a052..4715339 100644
--- a/flake.nix
+++ b/flake.nix
@@ -60,37 +60,6 @@
           naersk = inputs.naersk;
           pkgs = import inputs.nixpkgs { inherit system; };
           home-manager = inputs.home-manager.defaultPackage."${system}";
-          pre-commit-golang = pkgs.callPackage
-            ({ stdenv, fetchFromGitHub }:
-              stdenv.mkDerivation rec {
-                pname = "pre-commit-golang";
-                version = "0.5.0-96221dc";
-                src = fetchFromGitHub {
-                  owner = "dnephin";
-                  repo = pname;
-                  rev = "96221dc741cb30cc0136999083dc6bd0e2113000";
-                  sha256 = "sha256-lIQBoT+UIlVGnFaaGBgXag0Lm1UhGj/pIGlCCz91L4I=";
-                };
-                dontBuild = true;
-                dontConfigure = true;
-                installPhase = ''
-                  runHook preInstall
-                  install -d $out
-                  find . -type f -name 'run-*.sh' \
-                  | sed -E 's:^\./run-(.*)\.sh:\1:' \
-                  | xargs -I {} install ./run-{}.sh $out/{}
-                  runHook postInstall
-                '';
-              })
-            { };
-          pre-commit-golang-hook = name: {
-            "${name}" = {
-              inherit name;
-              enable = true;
-              entry = "${pre-commit-golang}/${name}";
-              files = "\\.go$";
-            };
-          };
         in
         rec
         {
@@ -132,9 +101,7 @@
                   files = "\\.sh$";
                   types_or = [ "file" ];
                 };
-              }
-              // (pre-commit-golang-hook "go-fmt")
-              // (pre-commit-golang-hook "go-mod-tidy");
+              };
             };
           };