about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-08 16:24:28 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-08 16:24:28 -0800
commit12566edfda699730e3e28fb97077dfed8b3e8844 (patch)
treeb2bfce3aaf6265c98818bff8d3d6ae538506871b /flake.nix
parenthome: initial configuration for home manager (diff)
downloadworld-12566edfda699730e3e28fb97077dfed8b3e8844.tar.gz
home-manager: fix initial configuration
This configuration is working, and I'm still unclear of how this is
supposed to be done correctly. Might need to iterate a few more times.
Diffstat (limited to '')
-rw-r--r--flake.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 5c5f782..2accd12 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,6 +26,15 @@
           ./users/fcuny
           ./modules/systems
           ./modules/desktop
+          home-manager.nixosModules.home-manager {
+            home-manager.useGlobalPkgs = true;
+            home-manager.useUserPackages = true;
+            home-manager.users.fcuny = {
+              imports = [
+                ./users/fcuny/home-manager.nix
+              ];
+            };
+          }
         ];
       };
     };