summary refs log tree commit diff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL16
1 files changed, 7 insertions, 9 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 66c30e9..6fc7579 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,9 +1,7 @@
-use ExtUtils::MakeMaker;
-WriteMakefile(
-    'NAME'      => 'WebService::Google::Suggest',
-    'VERSION_FROM' => 'lib/WebService/Google/Suggest.pm', # finds $VERSION
-    'PREREQ_PM' => {
-	Test::More => 0.32,
-	LWP::UserAgent => 0,
-    },
-);
+use inc::Module::Install;
+name 'Webservice-Google-Suggest';
+all_from 'lib/WebService/Google/Suggest.pm';
+requires 'LWP::UserAgent';
+build_requires 'Test::More';
+auto_set_repository;
+WriteAll;