summary refs log tree commit diff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorfranck cuny <franck@lumberjaph.net>2009-11-10 17:43:10 +0100
committerfranck cuny <franck@lumberjaph.net>2009-11-10 17:43:10 +0100
commit1ed5356fbeac64e156dfd68f56fadeb523246a27 (patch)
treefff04828ba0d90b29d5d408707b62d8d4b4e2cec /Makefile.PL
parentadd .gitignore (diff)
downloadwebservice-google-suggest-1ed5356fbeac64e156dfd68f56fadeb523246a27.tar.gz
Checking in changes prior to tagging of version 0.04. Changelog diff is: 0.04
diff --git a/Changes b/Changes
index 27e3a76..f0c7b23 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,8 @@
 Revision history for Perl extension WebService::Google::Suggest

+0.04  Tue 10 Nov 2009 05:26:27 PM CET
+        - Fixed per Google Suggest JavaScript updates
+
 0.03  Thu Oct 11 14:35:12 PDT 2007
         - Fixed per Google Suggest JavaScript updates
           (Thanks to Lorimier Loic)
Diffstat (limited to '')
-rw-r--r--Makefile.PL16
1 files changed, 7 insertions, 9 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 66c30e9..6fc7579 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,9 +1,7 @@
-use ExtUtils::MakeMaker;
-WriteMakefile(
-    'NAME'      => 'WebService::Google::Suggest',
-    'VERSION_FROM' => 'lib/WebService/Google/Suggest.pm', # finds $VERSION
-    'PREREQ_PM' => {
-	Test::More => 0.32,
-	LWP::UserAgent => 0,
-    },
-);
+use inc::Module::Install;
+name 'Webservice-Google-Suggest';
+all_from 'lib/WebService/Google/Suggest.pm';
+requires 'LWP::UserAgent';
+build_requires 'Test::More';
+auto_set_repository;
+WriteAll;