summary refs log tree commit diff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorfranck cuny <franck@lumberjaph.net>2010-08-11 09:59:29 +0200
committerfranck cuny <franck@lumberjaph.net>2010-08-11 09:59:29 +0200
commitafb209cbcfae7b88d8fb23ed04c47e1aee187b2a (patch)
tree6b113aedc62a3ad0548a157d74054ec096720ddd /Makefile.PL
downloadmoosex-abstractfactory-afb209cbcfae7b88d8fb23ed04c47e1aee187b2a.tar.gz
initial commit
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..43b60d1
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,18 @@
+# Load the Module::Install bundled in ./inc/
+use inc::Module::Install;
+
+# Define metadata
+name            'MooseX-AbstractFactory';
+all_from        'lib/MooseX/AbstractFactory.pm';
+
+# Specific dependencies
+requires        'Moose'				=> 0;
+requires        'Moose::Autobox'    => 0;
+build_requires  'Test::Moose'		=> 0;
+build_requires  'Test::Exception'	=> 0;
+
+use_test_base;
+use_standard_tests;
+
+auto_install;
+WriteAll; 
\ No newline at end of file