about summary refs log tree commit diff
path: root/treefmt.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-07-03 16:47:38 -0700
committerFranck Cuny <franck@fcuny.net>2024-07-03 16:47:38 -0700
commitccfdb6a3351aec0022e2660478a39263addc42d7 (patch)
tree8d15ec4f8cc6d78c6a4e6966cff77c8d8940df2f /treefmt.nix
parentsome more cleanup (diff)
downloadfcuny.net-ccfdb6a3351aec0022e2660478a39263addc42d7.tar.gz
dont format html files with prettier
Diffstat (limited to '')
-rw-r--r--treefmt.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/treefmt.nix b/treefmt.nix
index d9dc0e6..2fecfa5 100644
--- a/treefmt.nix
+++ b/treefmt.nix
@@ -6,4 +6,11 @@
     yamlfmt.enable = true; # yaml
     prettier.enable = true; # css
   };
+  settings.formatter = {
+    prettier = {
+      includes = [ "*.css" "*.md" ];
+      excludes = [ "*.html" ];
+      options = [ "-w" ];
+    };
+  };
 }