summary refs log tree commit diff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorfranck cuny <franck@lumberjaph.net>2011-03-12 20:24:59 +0100
committerfranck cuny <franck@lumberjaph.net>2011-03-12 20:24:59 +0100
commit88dc5c48a1766d9440a1e176d579dfe4714f6ed4 (patch)
tree4c362d486f03e4c735086b107a041ddc566b28ed /Makefile.PL
downloadballet-88dc5c48a1766d9440a1e176d579dfe4714f6ed4.tar.gz
initial import
Diffstat (limited to '')
-rw-r--r--Makefile.PL21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..7604f23
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,21 @@
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+    NAME                => 'ballet',
+    AUTHOR              => q{YOUR NAME <youremail@example.com>},
+    VERSION_FROM        => 'lib/ballet.pm',
+    ABSTRACT            => 'YOUR APPLICATION ABSTRACT',
+    ($ExtUtils::MakeMaker::VERSION >= 6.3002
+      ? ('LICENSE'=> 'perl')
+      : ()),
+    PL_FILES            => {},
+    PREREQ_PM => {
+        'Test::More' => 0,
+        'YAML'       => 0,
+        'Dancer'     => 1.3011,
+    },
+    dist                => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+    clean               => { FILES => 'ballet-*' },
+);